seltsames WordPress-Verhalten

[Update2] Na toll, nun ist WP 3.2 da und damit ist alles hier unten obsolet und egal 😉 [Update2]

[Update] Jetzt gerade habe ich das noch mal passiert und alles ging fehlerfrei wie gewohnt… ich kann also leider keine Lösung für diesen Fehler liefern.[Update]

Gerade hatte ich einen komischen Effekt, als ich den letzten Artikel publizieren wollte. ich bekam eine Fehlermeldung. Völlig ungewohnt. Zum Glück konnte ich durch den Zurück-Button meines Safaris den eigentlichen Artikel-Inhalt noch retten, denn aus lauter Gewohnheit und dem Vertrauen in WordPress habe ich den Text natürlich nicht vorher irgendwo gesichert. Ich mache das nun noch mal und gucke, was passiert:

Siehste, da war wieder die Fehlermeldung:

1309738868
Warning: Cannot modify header information – headers already sent by (output started at /var/www/clients/client3/web2/web/wordpress/wp-includes/general-template.php:1438) in/var/www/clients/client3/web2/web/wordpress/wp-includes/pluggable.php on line 897

Seltsam. Nichts hier im Dashboard deutet darauf hin, dass der Artikel publiziert ist. Sogar der Titel ist weg und statt des Permalinks steht dort nur eine Nummer. Aber:

Rufe ich lerigau.de über meinen Firefox am gleichen Rechner auf, dann ist der Artikel schon publiziert, mit Titel:

 

Und das einzige, was ich heute gemacht habe: Ich habe auf WordPress 3.1.4 aktualisiert und das Flattr-Plugin auf die neuste Version (die laut Changelog nur einen Typo-Fehler im Quelltext hatte).

Den Beitrag speichern kann ich. Aber nur einmal. Dann ist der Speicherbutton verschwunden. Und wenn ich erneut publiziere, dann kommt wieder der Fehler aber der Artikel ist aktualisiert.

Zum Glück habe ich vorher noch ein aktuelles Backup gezogen. Wenn der Fehler wirklich im neuen WP liegt, dann spiele ich die alte Version wieder ein und mache sobald kein Update mehr.

Gleich werde ich noch testweise Flattr deaktivieren. Moment bitte 😉

(Flattr-Plugin ist deaktiviert) Alles verhält sich hier völlig falsch. Ich konnte gerade nach „Moment bitte“ ohne Fehlermeldung auf „Publizieren“ klicken und danach habe ich rechts einen neuen Button „Als unerledigt speichern“. Schaue ich nun wieder mit dem Firefox auf mein Blog, dann sehe ich: Der VORletzte Speicherpunkt ist nun online, nicht der aktuelle.

Ich belasse es mal für heute dabei. Entweder ich merke morgen, was ich falsch gemacht habe oder andere merken, was schief gegangen ist 😉 Und was ich noch gerade sehe: Die Artikel sind mehrfach vorhanden. tze. Das ist ja doof. Also morgen ein Restore vom Backup: Wo auch immer der Fehler liegt, vorher ging es.

Flattr this!

1 comment for “seltsames WordPress-Verhalten

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.