Magazine Basic

Lerigau.de damals

Neulich haben wir doch erst drüber gesprochen und nun ist es schon passiert: Ich habe mich für ein neues Theme (Magazine Basic) entschieden. Mir gefällt die strukturierte Anzeige der einzelnen Artikel, die Anzeige der Kategorien im Headerbereich und es ist trotz der Schlichtheit nicht zu simpel. Einzig die Seitenauswahl (Page x of y) am unteren Rand funktioniert (noch) nicht. Aber da bin ich noch dran. Dank dem Alex konnte der fehlerhafte Skriptteil im Theme gefunden werden. Ich will das merkwürdige Fehlverhalten mal näher beschreiben:

Am unteren Seitenrand gibt es eine Leiste, um durch die einzelnen Seiten zu klicken:

Und da ich Permalinks nutze, haben diese Knöpfe nicht funktioniert, da ein falscher Link hinterlegt war (lerigau.de/page/2). Ohne Permalinks geht es fehlerfrei! Dieses Verhalten tritt übrigens nur auf der Hauptseite auf, in den Kategorien hat es immer funktioniert (z.B. http://lerigau.de/index.php/category/technisches/page/2/?paged=3). Also gibt es aus irgend einem Grund einen Unterschied in der Skriptverarbeitung bei den diversen Seiten. Im Dashboard hat man bei den Theme-Einstellungen ja immer Möglichkeiten, die Skripte direkt anzupassen (Editor). Sucht man in den dort aufgelisteten Dateien nach „Page“, dann finden sich da nur noch zwei Skripte und in der functions.php war ein Stück Code, welches offenbar für die falsche Linkgenerierung verantwortlich war. Man kann in der Datei nach „pagination“ suchen, dann findet sich so ziemlich zum Ende des Skriptes folgender Teil:

if( $wp_rewrite->using_permalinks() )

$pagination[‚base‘] = user_trailingslashit( trailingslashit( remove_query_arg( ’s‘, get_pagenum_link( 1 ) ) ) .

‚page/%#%/‘, ‚paged‘ );

Ohne gross auf Fehlersuche zu gehen kann man diesen Part einfach auskommentieren (z.B. mit /* */ im Block oder // vor den Zeilen) und danach funktioniert alles offenbar wie gewünscht.

Falls keine grösseren Macken oder Beschwerden auftauchen bleibt das Blog mit diesem Theme erstmal so 🙂

Flattr this!

2 comments for “Magazine Basic

  1. 7. Mai 2012 at 22:43

    Du solltest das RSS Widget einschalten damit man deine RSS-Feeds einfacher abonnieren kann…

  2. 7. Mai 2012 at 23:06

    das macht bei mir leider nicht das, was ich erwarte… die feed-URL wird nicht hinterlegt 🙁

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.